시작페이지로 즐겨찾기추가
로그인
회원가입 l 출석체크 l 마이페이지 l CGIMALL
자료실 사이트등록 랭킹100 프로그램리뷰 관리자추천자료 초보가이드
커뮤니티
전체 펼쳐보기
퀵메뉴링크 jquery , CSS , PHP , Javascript , 무료폰트 , ASP
상세검색
> 커뮤니티 > 질문과답변 상세보기
커뮤니티 구인구직
사이트등록
현재접속자 새로고침
게시판타이틀 질문과답변 / 상세보기
트위터로 보내기 미투데이로 보내기 싸이월드 공감
추천수 388 | 조회수 2,961 | 등록일 2014-05-20 09:51:57

닉네임

쭈니

이메일

jun7686@hanmail.net

제목

웹상에서 cgi 실행하면 다운로드가 됩니다..
내용
우분투  아파치 설정(000-default.conf)에서

 
ScriptAlias /cgi-bin/ /var/www/cgi-bin/
<Directory "/var/www/cgi-bin/">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
AddHandler cgi-script cgi pl
Order allow,deny
Allow from all
</Directory>

이렇게 했는데도 실행이 안되고 다운로드가 되네요..
어떻게 하면 될까요??
추천스크랩소스보기 목록
쭈니 2014-05-20 20:50:01
답글

처음엔 퍼미션 문제 라고 해서 조정했는데 다운이되버리네요 실행이 안되구요~;

코딩쟁이 2014-05-21 10:19:07
답글

실행이 안되고 다운로드가 된다는 말이 웹상에서 호출을 하면 바로 다운이 되버린다는 말씀이신가요?
자세한 내용을 모르고서는 정확한 답변을 드리기는 힘들지만
scriptalias /cgi-bin/ /var/www/cgi-bin/
이 부분을 주석처리하고 개인 디렉토리에 /cgi-bin/ 디렉토리를 만들고 거기 넣어서 테스트 해보세요.
서버관련 전문가가 아니라서 정확하고 구체적인 답변을 드리지는 못하는 점 양해바래요~

HappyCGI 2014-05-22 17:43:11
답글

다운로드가 되는 증세는 아마도 서버에서 "너는 실행하는게 아니구나" 하고 인식하는 겁니다.
아파치의 conf 에서 실행되는 애 입니다~ 라고 지정해주셔야 해요.
php의 경우 php.ini 에서 php가 구동되는 경로를 설정하듯이 cgi의 경우 아파치 conf 에서
해당 경로에서 cgi가 실행되는거라 인식을 시켜줘야 합니다.

쭈니 2014-05-23 00:23:09
답글

HappyCGI// 감사합니다.

CGI 다운로드 문제 해결
아래같이 하니 해결되더라구요

sudo ln -s /etc/apache2/mods-available/cgi.load /etc/apache2/mods-enabled/cgi.load

service apache2 restart

-------------------
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch 에서

-MultiViews +SymLinksIfOwnerMatch 이것도 삭제하구요

HappyCGI 2014-06-03 15:02:52
답글

축하드려용.

이전게시글 CrazyGuestbook 설치하고 있습니다.. 도와주세요... ㅠㅠ 2014-05-20 08:37:40
다음게시글 플래시 적용(수정) 도와주세요 2014-05-29 10:15:07